Results 1 to 2 of 2
  1. #1
    #whyallthehashtags
    AOD_Rafke_C's Avatar
    Rank
    Sergeant
    Division
    Tom Clancy
    Status
    Active
    Join Date
    Jan 2016
    Location
    Antwerp
    Age
    36
    Posts
    1,870

    Default BSOD after pluggin in my G920

    last night i tried to install my racing gear (logitech G920) on my PC
    at first i plugged in the device on a USB 3.0 port at the front of my desktop, everything reacted as it should
    then i downloaded the logitech gaming software
    software gave me a firmware update notification
    after i did the firmware update my pc crashed (BSOD)
    When my pc restarted... no issues untill i plugged in the USB >> the device does its intial "turning" and suddenly the BSOD pops up
    i used to play with it on my laptop (running on Windows 8.1) and on my laptop it still works (double checked it)
    i already tried to delete drivers and re install them >> did not work
    tried to make a restore and re install >> did not work
    PLease Help? thx!

    fault message: system.thread.exception.not.handled (Wdf01000.sys)
    os: Windows 10
    mobo: asus maximus VIII Hero (1151)
    cpu: i5 6600K
    gpu: gtx 970 (MSI)

  2. #2
    #whyallthehashtags
    AOD_Rafke_C's Avatar
    Rank
    Sergeant
    Division
    Tom Clancy
    Status
    Active
    Join Date
    Jan 2016
    Location
    Antwerp
    Age
    36
    Posts
    1,870

    Default

    fixed!
    deleted all! drivers including hidden one's
    deleted LGS
    deleted visual CC+ that comes with it

    then re installed wheel >> LGS >> wheel now works perfect!


 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
vBulletin Skin By: ForumThemes.com
Top