Results 1 to 3 of 3

Thread: New PC...

  1. #1
    Looks like I picked the wrong week to quit sniffing glue Parker101200's Avatar
    Rank
    Forum Member
    Division
    None
    Status
    Active
    Join Date
    Jan 2016
    Location
    Des Moines
    Age
    20
    Posts
    32

    Default New PC...

    So, finished building my PC finally... And it doesn't turn on. I've been checking the plugs, reading the manuals, looking up videos for the past 5-6 hours. Idk wtf to do rn. Feel like one of the parts that was delivered was broken or something...... everything is where it's supposed to be. Any ideas would be great...

  2. #2
    Looks like I picked the wrong week to quit sniffing glue Sense of Right League's Avatar
    Rank
    Forum Member
    Division
    None
    Status
    Active
    Join Date
    Feb 2016
    Posts
    35

    Default

    I would take my opinion with a heap of salt but if it doesn't turn on at all it could be a PSU, CPU or mobo issue. I haven't built my own yet but I would assume that it would at least turn on and show BIOS if those three bits are in working condition and installed right...

    Could always take it to a PC shop and get it checked out worst case scenario because nobody on the internet's gonna have the thing to physically check.

  3. #3
    Looks like I picked the wrong week to quit sniffing glue Parker101200's Avatar
    Rank
    Forum Member
    Division
    None
    Status
    Active
    Join Date
    Jan 2016
    Location
    Des Moines
    Age
    20
    Posts
    32

    Default

    I GOT IT HAHAHAHAHA..... im too hyped rn.. it was a grounding issue. I didn't have a slot for a screw, but on my case, there was a mounting port listed ATX, so i put one in and it works!!!! AKDJFHASKDFHKASDHFKASHDKFHASDKFHAK
    Last edited by AOD_Derek Jeter; 03-10-2016 at 05:23 AM.


 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
vBulletin Skin By: ForumThemes.com
Top