I had an issue with my mic that would speed up the sound so fast that it sounded like I was a chipmunk on speed. I finally found the answer to this issue.

All you have to do is close out Vent, go into your sound devices, disable your microphone for about 10 seconds, then re-enable it (you may have to right click in the list and choose the "See Disabled Devices" box).

This plagued me for the longest time, and I couldn't find any information on the problem. I hope someone finds this information useful.